Payments are unavailable
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 16:33 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2024 - 16:02 EST
Update
We are continuing to investigate this issue.
Posted Jan 16, 2024 - 15:00 EST
Investigating
We are currently unable to process payments and are working with our vendor to resolve the issue.
Posted Jan 16, 2024 - 14:59 EST
This incident affected: Billing Services (Billing Systems).