Phone System Trouble
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 14:28 EDT
Monitoring
We believe that the problem is fixed, but will continue to monitor the situation for the next hour.
Posted Mar 27, 2024 - 13:13 EDT
Investigating
We are having problems receiving calls. We are investigating.
Posted Mar 27, 2024 - 12:22 EDT
This incident affected: Communication Services (Telephone).