Payment system unavailable.
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 10:12 EDT
Monitoring
Our payment processing vendor was experiencing issues. These appear to be resolved but we will continue to monitor the situation.
Posted Sep 12, 2024 - 09:40 EDT
Investigating
The ability to make payments is currently unavailable. We are investigating.
Posted Sep 12, 2024 - 09:06 EDT
This incident affected: Billing Services (Billing Systems).